Apa itu AppCompat Library dan Mengatasi Error android.support.v7.app.AppCompatActivity

ERROR android.support.v7.app.AlertDialog;


Selamat siang Sahabat Fandi Media.

Apa itu AppCompat Library dan Mengatasi 

Error android.support.v7.app.AppCompatActivity

Sudah beberapa kali update, kami admin FandiMedia.com mulai mengulas tentang Android Studio, Banyak pemula seperti admin sendiri yang kesulitan untuk Belajar Android Studio ini. Dan mulai hari ini kami dari Tim FandiMedia akan menyediakan Menu Khusus untuk Tutorial dan Belajar Android studio dengan mudah.

Oke, pada kali ini saya akan Update Informasi Bagaiman Mengatasi Error yang terjadi pada Android Studio, Yaitu :

           Error: import android.support.v7.app.AppCompatActivity;

                    android.support.v7.app.AlertDialog;

AppCompat adalah sebuah Library yang biasanya digunakan untuk mengimplementasikan ActionBar/Toolbar dan Material Design pada aplikasi yang kita buat di Android Studio. Tapi saat ini penggunaan AppCompat Library sudah menjadi default (bawaan), saat kita membuat project pada Android Studio. 

Error pada import android.support.v7.app.AppCompatActivity; ini biasanya terjadi pada saat kita melihat tutorial belajar android studio versi lama. 

Sejak tahun 2021 berdasarkan Artikel yang saya baca, dan sudah saya praktekan juga bahwasanya, Library

android.support.v7.app.AppCompatActivity;

ini sudah bisa digantikan menjadi :

androidx.appcompat.app.AppCompatActivity;                

Artinya anda tidak perlu lagi mencari Library Support V 7 tersebut, karena Library Tersebut sudah dapat digantikan Andoidx di atas.

Artinya Library V7 tersebut tidak perlu lagi, Jika kita sudah Pake Android Studio 2020 Ke atas.

Namun jika belum ada Androidx nya silahkan download di Librarynya di

 Projeck Structure >> Dependencies >> Tambahkan Library nya


 

*** Fandi Media ***

0 Response to "Apa itu AppCompat Library dan Mengatasi Error android.support.v7.app.AppCompatActivity"

Post a Comment